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Overview

This exercise demonstrates a terminal application using the Actel Fusion System Management board. The CoreMP7 microprocessor is implemented in a Fusion M7AFS600 PSC.

Figure 1 is a block diagram of the design. The ARM7 system contains the following:

· Two UARTs – one to communicate with the RS232-port and one to communicate with an Actel A3P250 used as a port expansion device to control the user interfaces such as the LCD, LEDs, keypad, etc.

· CoreAI – the ARM7 interface to the Fusion peripherals

· CoreNVM and CoreSRAM – the ARM7 interface to the Fusion Flash Memory and SRAM

This workshop guide will take you through all the steps to build, download, and debug the ARM7 application.
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Figure 1:  Block Diagram of ARM7 Subsystem
Lab 1

Using SoftConsole

Objectives

Using the Actel SoftConsole software, you will do the following:

· Open a project containing C-language source code for the terminal application

· Generate the application code

· Download the application code to the Fusion System Management board and run a sample application

· Make modifications to the code, then download and run the modified application

Step 1 – Confirming Board Connections

1. Confirm that the power supply and FlashPro3 are connected to the board and that the serial cable is connected between the board and your PC. Ask the lab instructor if you have any questions.

2. Apply power to the board by moving the on/off switch (SW7) to the ON position (Figure 2).
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Figure 2:  System Management Board Connections

Step 2 – Opening SoftConsole

1. Open SoftConsole by double-clicking the Actel SoftConsole 1.1 shortcut on the desktop of your PC.

2. If necessary, open the C/C++ perspective by choosing Window > Open Perspective > C/C++ from the SoftConsole menu. The C/C++ perspective will open, as shown in Figure 3. If your C/C++ view is already open, you will not see C/C++ under Open Perspective.
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Figure 3:  SoftConsole C/C++ Perspective

3. Select ESC_workshop2 in the C/C++ Projects window, and open the project by choosing Project > Open Project from the SoftConsole menu. Click No if prompted about opening referenced projects.

4. The SoftConsole project will open, as shown in Figure 4.
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Figure 4:  SoftConsole after Opening the Project

5. Click the + sign next to ESC_workshop2 on the C/C++ Projects tab to expand the list of files in the project.

6. Open the file esc07.c by double-clicking the file under the C/C++ Projects tab (Figure 5). The file esc07.c holds the main() function and should look familiar to C programmers. Maximize the window (Figure 6), and browse in the SoftConsole editor to become familiar with it. Minimize the editor when you are finished browsing.
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Figure 5:  esc07.c in SoftConsole Editor
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Figure 6:  esc07.c Maximized in SoftConsole

Step 3 – Generating the Application Code and Downloading to the System Management Board

1. Choose Project > Clean from the SoftConsole menu. SoftConsole will compile the source files and generate a HEX file for downloading. Select ESC_workshop2 in the Clean dialog box (Figure 7) and click OK.
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Figure 7:  SoftConsole Clean Dialog

2. Confirm that no errors are shown under the Problems tab (Figure 8). Ignore the warning messages shown.
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Figure 8:  SoftConsole Problems Tab

3. Open the communication client for the FlashPro3 debugger by choosing Run > External tools > FlashPro3 On-Chip Debugging for CoreMP7. An FS2 Console window will open in the background and minimize automatically. Do not close the FS2 window.

4. Choose Run > Debug from the SoftConsole menu. The Debug window will open (Figure 9).
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Figure 9:  SoftConsole Debug Window

5. Select ESC_workshop2 under Embedded Debug in the left-hand window and click Debug. The code will be automatically downloaded to the System Management board.

6. Click Yes in the Confirm Perspective Switch dialog box. The SoftConsole Debug perspective will open (Figure 10).
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Figure 10:  SoftConsole Debug Perspective

Step 4 – Running the Application

1. Open the HyperTerminal session file by double-clicking the shortcut on the desktop of your PC (Figure 11).
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Figure 11:  HyperTerminal Shortcut

2. Start the application by clicking Run > Resume from the SoftConsole menu. The HyperTerminal window display will appear, as shown in Figure 12. In addition, the LCD on the System Management board will display the following message:

“Actel & Avnet
Fusion Workshop”
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Figure 12:  HyperTerminal when Running Application

3. Experiment with different commands to send messages to the LCD or read the temperature sensor and potentiometer on the Fusion System Management board.
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Figure 13:  System Management Board

Step 5 – Debugging

In this step, you will insert breakpoints, view the contents of the processor registers, and view variable values and assembly instructions. You will also single-step through the code and view lines that are being executed.

1. Place the cursor on line 48 in esc07.c and choose Run > Toggle Line Breakpoint from the SoftConsole menu (Figure 14). This will cause execution to stop when the character C is entered in the HyperTerminal window.

Note: You can also enter a breakpoint or remove a set breakpoint by selecting the line in the source file, right-clicking, and choosing Toggle Breakpoint.
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Figure 14:  Adding a Breakpoint in esc07.c
2. Breakpoints are visible on the Breakpoints tab in the upper right window pane of the Debug perspective (Figure 15).
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Figure 15:  SoftConsole Breakpoints Tab

3. Enter the character C in the HyperTerminal window to force the code to break.

4. Select the Registers tab on the upper right window pane to view the value of the processor’s internal registers (Figure 16).
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Figure 16:  SoftConsole Registers Tab
5. Select the Variables tab in the upper right window pane to view the value of variables in the source code (Figure 17). By default, variables are displayed in Natural format (an integer value). To display the contents in hexadecimal format, right-click a variable name and choose Format Hexadecimal.
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Figure 17:  SoftConsole Variables Tab

6. Choose Window > Show View > Disassembly to display the assembly instructions that are being executed. The Assembly window will open on the right side in the middle of the Debug perspective (Figure 18).
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Figure 18:  Viewing Assembly Instructions in the Debug Perspective
7. You can single-step through the code by choosing Run > Step Into or Run > Step Over, or by clicking the Step Into [image: image19.png]


 and Step Over [image: image20.png]


 icons. Observe the changes in the source code window and the Disassembly window. Performing Step Over executes a single line of C source code that may contain several assembly instructions.

8. Click the Instruction Stepping [image: image21.png]i



 icon and then perform Step Over operations. Observe that Step Over now executes a single line of assembly code.

9. Click the Instruction Stepping icon to exit instruction stepping mode. Single-step through the application and observe the instruction sequence in the source code window in the middle of the Debug perspective, and the values of the variables and registers (Figure 19).
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Figure 19:  Source File Window in the Debug Perspective

10. Resume execution of the code by choosing Run > Resume or by clicking the Resume icon.

11. Add breakpoints in other sections of the application. Enter commands in the HyperTerminal window to force the code to halt, then single step and observe the instruction sequence.

12. Select ESC_workshop2[Embedded debug] under the Debug tab in the upper left corner of SoftConsole. Right-click and choose Terminate and Remove to stop the debugger (Figure 20).
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Figure 20:  Stopping the Debugger

Lab 2

Modifying the Source Code

In this lab, you will modify the source code, compile, generate the application, and download it to the Fusion System Management board. The modified code will display the voltage reading on the LCD and illuminate the tricolor LED as follows:

	Voltage 
	Color

	Less than 2.56 V
	Blue

	2.56 V to 4.5 V
	Green

	Greater than 4.5 V
	Red


Step 1 – Modifying the Source Code

1. Select the C/C++ perspective by clicking Window > Open Perspective > C/C++.

2. Maximize the window pane containing the file esc07.c, located in the center of the SoftConsole C/C++ perspective (Figure 21).
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Figure 21:  esc07.c in the SoftConsole C/C++ Perspective

3. Uncomment lines 142–154 and 157–171 in esc07.c. You can quickly uncomment the lines by highlighting the lines and then right-clicking and choosing Uncomment, as shown in Figure 22.
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Figure 22:  Removing Commented Lines in esc07.c
4. Save the file by choosing File > Save from the SoftConsole menu. SoftConsole will compile the source code and build the new application automatically.

5. Restore the window pane containing esc07.c to the original size.

6. Confirm there are no errors under the Problems tab at the bottom of the C/C++ perspective (Figure 23).
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Figure 23:  Problems Tab in C/C++ Perspective

Step 2 – Downloading and Running the Modified Code

1. Select the Debug perspective by clicking Window > Open Perspective > Debug.

2. Start the debugger by selecting Run > Debug Last Launched from the SoftConsole menu. The modified code will be downloaded to the System Management board.

3. Disable any breakpoints set in the previous section by choosing Run > Remove all breakpoints from the SoftConsole menu.

4. Start the application by choosing Run > Resume from the SoftConsole menu.

5. Select the HyperTerminal window and enter the V command. Observe that the Voltage reading will now be displayed on the LCD. Also observe the operation of the tricolor LED located near the potentiometer. Try different voltage values by adjusting the potentiometer, then entering the V command in the HyperTerminal window. Observe the voltage readings on the LCD and the color of the LED.

Lab 3

Correcting Errors in the Source Code

In this lab, you will modify the source code to display the temperature on the LCD. After modifying the code, you will compile, generate the application, and download it to the Fusion System Management board. The existing code has a bug and does not display the temperature correctly. Change the code as needed so the temperature appears on the LCD correctly.

Step 1 – Uncommenting Lines in the Source Code

1. Stop the debugger by selecting ESC_workshop2[Embedded debug] under the Debug tab in the upper left corner of SoftConsole. Right-click and choose Terminate and Remove to stop the debugger, as shown in Figure 20.

2. Select the C/C++ perspective by clicking Window > Open Perspective > C/C++.

3. Maximize the window pane containing the file esc07.c, located in the center of the SoftConsole C/C++ perspective (Figure 21).

4. Uncomment lines 109–122 in esc07.c.

5. Save the file by choosing File > Save from the SoftConsole menu. SoftConsole will compile the source code and build the new application automatically.

6. Restore the window pane containing esc07.c to the original size.

7. Confirm there are no errors under the Problems tab at the bottom of the C/C++ perspective (Figure 23).

Step 2 – Downloading and Running the Modified Code

1. Select the Debug perspective by clicking Window > Open Perspective > Debug.

2. Restart the debugger by choosing Run > Debug Last Launched from the SoftConsole menu. The modified code will be downloaded to the System Management board.

3. Disable any breakpoints set in the previous section by choosing Run > Remove all breakpoints from the SoftConsole menu.

4. Start the application by choosing Run > Resume from the SoftConsole menu.

5. Select the HyperTerminal window and enter T to display the temperature. Observe that the Temperature reading shown on the LCD is not correct.

Step 3 – Debugging and Correcting the Code

1. Set a breakpoint at line 114. Enter T in the HyperTerminal window to force the breakpoint to activate.

2. Single-step through the code and observe the variable and register values to determine the cause of the code problem.

3. Stop the debugger and open esc07.c in the editor. Review lines 109–122 and make changes to correct the temperature display on the LCD. Save the changes when you are finished.

4. Remove the breakpoint at line 114 by choosing Run > Remove all breakpoints from the SoftConsole menu.

5. Restart the debugger and run the application. Enter T in the HyperTerminal window and observe the Temperature display on the LCD.

6. When finished, stop the debugger by selecting ESC_workshop2[Embedded debug] on the Debug tab in the upper left corner of SoftConsole. Right-click and choose Terminate and Remove.

7. Remove the communication client for the FlashPro3 debugger by selecting FlashPro3 On-Chip Debugger for CoreMP7 [Program] under the Debug tab. Right-click and choose Terminate and Remove (Figure 24).
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Figure 24:  Terminating the Communication Client for FlashPro3

8. Remove all the breakpoints by choosing Run > Remove all breakpoints from the SoftConsole menu.

9. Close the SoftConsole Debug perspective by choosing Window > Close Perspective.

10. Close SoftConsole by choosing File > Exit. Choose Yes when prompted about exiting.

11. Close the HyperTerminal window by choosing File > Exit. Click Yes when prompted about disconnecting.

Congratulations! You have downloaded and debugged code for an ARM7 processor running in an Actel Fusion FPGA.

Appendix – ARM7 System Memory Map

	
	Base Address 

	
	CoreAHBLite_00:NoRemap 
	CoreAHBLite_00:SwapSlots0and1 

	CoreAhbNvm_00 
	0x00000000
	0x10000000

	CoreAhbSram_00 
	0x10000000
	0x00000000

	CoreAI_00 
	0xc1000000
	

	CoreUARTapb_00 
	0xc3000000
	

	CoreUARTapb_01 
	0xc5000000
	


CoreAhbNvm_00, Nonvolatile Memory Map

Range: 0x40000

CoreAhbSram_00, IRAM Memory Map

Range: 0x2800

CoreUARTapb, RegisterMap Memory Map

	Address
	Type
	Width
	Reset Value
	Name
	Description

	Base address + 0x0
	Write-only
	8
	0x0
	TxData
	

	Base address + 0x4
	Read-only
	8
	0x0
	RxData
	

	Base address + 0x8
	Read/write
	8
	0x0
	ControReg1
	

	Base address + 0xC
	Read/write
	8
	0x0
	ControReg2
	

	Base address + 0x10
	Read-only
	8
	0x0
	StatusReg
	


CoreAI_00, RegisterMap Memory Map

	Address
	Type
	Width
	Reset Value
	Name
	Description

	Base address + 0x00
	Read/write
	16
	0x0
	ACM_CTRL_STATUS
	ACM Control Status Register

	Base address + 0x04
	Read/write
	16
	0x0
	ACM_ADDR
	ACM Address Register

	Base address + 0x08
	Read/write
	8
	0x0
	ACM_DATA
	ACM Data Register

	Base address + 0x0C
	Read/write
	16
	0x0
	ADC_CTRL_1
	ADC Control Register 1

	Base address + 0x10
	Read/write
	16
	0x0
	ADC_CTRL_2
	ADC Control Register 2

	Base address + 0x14
	Read/write
	16
	0x0
	ADC_CTRL_3
	ADC Control Register 3

	Base address + 0x18
	Read/write
	16
	0x0
	ADC_CTRL_4
	ADC Control Register 4

	Base address + 0x1C
	Read/write
	16
	0x0
	ADC_CTRL_5
	ADC Control Register 5

	Base address + 0x20
	Read-only
	16
	0x0
	ADC_STATUS
	ADC Status Register

	Base address + 0x24
	Read-only
	16
	0x0
	READ_FIFO_DATA_OUTPUT
	Read FIFO Data Output

	Base address + 0x28
	Read-only
	8
	0x0
	READ_FIFO_STATUS
	Read FIFO Status

	Base address + 0x2C
	Read/write
	16
	0x0
	IRQ_ENABLE
	Interrupt Enable Register

	Base address + 0x30
	Read-only
	16
	0x0
	IRQ_STATUS
	Interrupt Status Register



For more information, visit our website at http://www.actel.com
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